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What is Early Registration™?

When developing PowerPlant applications, the use of Constructor to define the user 
interface of your program requires you to solve two problems:

• UReanimator requires a table of “known” objects from which it builds the user inter-
face windows and views dynamically. We need a mechanism to make sure that this 
table is populated with a complete and accurate list of objects.

• The linker’s aggressive dead-stripping algorithms make sure that unused code is not 
included in your program. However, dead-stripping can be a problem when the 
information that a particular class is needed is primarily stored in a PPob resource 
created by Constructor and unavailable to the linker.

In PowerPlant, the URegistrar class addresses both these problems by providing a stan-
dard mechanism to populate UReanimator’s tables at compile time. And this compile-
time referencing of classes is sufficient to prevent the linker from dead-stripping the 
class from the application. But you still need to define the list of classes to be registered. 

So URegistrar transforms our problem into one of making sure every class that will be 
needed is actually registered. There are two obvious solutions:

• the kitchen sink approach — register all possible classes. The problem with this 
approach is that your application will be larger than it needs to be because it will 
include a bunch of classes that are never used.

• the selective approach — just register what you need. This approach avoids applica-
tion code bloat but puts the burden of keeping the list of registered classes up to date.

Early Registration was designed to automate the latter, selective approach.
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How it works Early Registration reads resource files, locating and parsing the PPob resources con-
tained in the file, using the parsing algorithm defined in UReanimator. It locates all of 
the objects and aliases defined in the file.

Early Registration also maintains databases of the standard PowerPlant objects and of 
local objects that you have created. Using these databases, Early Registration processes 
each object or alias it finds in your PPobs to place all of the objects it knows about into a 
list of known objects. Objects that are used in your database, but which are not currently 
known to Early Registration are placed in an unknown object list.

Using Early Registration, you can define the unknown objects (specifying information 
such as the class name associated with the object’s class_ID, the name of the include file 
containing its definition, etc). Once an object is defined, Early Registration updates its 
databases, so that you won’t have to redefine the object again (although you can update 
the definition later if something changes).

When you choose Save from the Early Registration File menu, the program generates a 
C++ file containing a registration function to register all of the functions used in your 
PPobs. So all you need to do is call this function from your application’s constructor to 
register these classes.

Example As an example, the following is the contents of the file that Early Registration generated 
for itself.

//-----------------------------------------------------
// PowerPlant Constructor Registration File
//
// Created by “Early Registration”
// © 1997 by Aurbach & Associates, Inc.
// All rights reserved worldwide.
//
//-----------------------------------------------------

void RegisterClass_ER_Resources(void);

#include    <URegistrar.h>
#include    "LEditFieldX.h"
#include    "LAlertBezel.h"
#include    "LBgView.h"
#include    <LCaption.h>
#include    "LCicnPane.h"
#include    "LChooseBox.h"
#include    <LGACaption.h>
#include    <LGADialogBox.h>
#include    <LGAPrimaryBox.h>
#include    <LGAPrimaryGroup.h>
#include    <LGAPushButton.h>
#include    <LGARadioButton.h>
#include    <LGASecondaryGroup.h>
#include    <LGATextButton.h>
#include    <LTabGroup.h>
#include    <LWindow.h>
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void RegisterClass_ER_Resources(void)  {
RegisterClass_(LEditFieldX); // ‘Edit’
RegisterClass_(LAlertBezel); // ‘aBzV’
RegisterClass_(LBgView); // ‘bgVw’
RegisterClass_(LCaption); // ‘capt’
RegisterClass_(LCicnPane); // ‘ccnP’
RegisterClass_(LChooseBox); // ‘chuz’
RegisterClass_(LGACaption); // ‘gcap’
RegisterClass_(LGADialogBox); // ‘gdlb’
RegisterClass_(LGAPrimaryBox); // ‘gpbx’
RegisterClass_(LGAPrimaryGroup); // ‘gpgp’
RegisterClass_(LGAPushButton); // ‘gpsh’
RegisterClass_(LGARadioButton); // ‘grad’
RegisterClass_(LGASecondaryGroup); // ‘gsgp’
RegisterClass_(LGATextButton); // ‘gtxb’
RegisterClass_(LTabGroup); // ‘tabg’
RegisterClass_(LWindow); // ‘wind’

}

As you can see from this example, Early Registration maintains all of the information 
needed to create the source file, including the name of the class, the name of its include 
file, whether the include file is a project or system include (so that it can generate an 
include file that either uses angle brackets or quotes), etc.

Early Registration will automatically create the name of your registration function, 
based on the name of the resource file it is processing. (In this case, Early Registration 
processed a file named “ER.Resources”.) However, you can change the name of the reg-
istration function if you wish. The default name of the output file is equal to the name of 
the input file with “.cp” appended. (In this example, Early Registration opened the file 
“ER.Resources” and used it to create the file “ER.Resources.cp”.) The output file is cre-
ated as a Metrowerks text file.

What You Get

When you download Early Registration from the Metrowerks PowerPlant archives, you 
will receive a demo version of the program. This version is functional, but has all of the 
features involved with editing, saving and updating its databases disabled. This means 
that the Early Registration Demo is able to create the output registration function file, 
but will not remember the definitions of your custom classes from run to run — you’ll 
need to redefine your custom classes every time you run the program.

Upon receipt of a $15 shareware fee (checks or purchase orders only — we’re unable to 
accept credit cards at this time), we will eMail you a full working version of Early Reg-
istration, complete will all sources, project files, etc. You’ll receive the program and its 
sources, plus the following utility classes we’ve developed at Aurbach & Associates:
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• LAlertBezel the 3D bezel we use for alert boxes and modal dialogs

• LAttachments3D some simple 3D frame attachments (see LChooseBox)

• LBgView a view that has a 3D bezel around it

• LChooseBox an LListBox with 3D effects and other enhancements

• LCicnPane a pane that displays a cicn (see UErrorAlert)

• LDFDocApplication an application class that handles deferred AppleEvents
during application startup.

• LEditFieldX an LGAEditField that notifies on keystrokes

• UErrorAlert a general alert handler

• UFileUtils some common file-handling utilities

• UGetFile a class that wraps CustomGetFile

• UProcessInfo a class that captures and maintains basic process info

• UPutFile a class that wraps CustomPutFile

• UStrFormat a generic string formatter class

• USystemCheck a class that wraps Gestalt

• XStandardFile the base class for UGetFile/UPutFile

As part of the shareware fee, you receive our permission to use these classes in your 
applications — in-house, shareware or commercial — without restriction, except that 
you may not resell these classes in source form. (And we regard it as professional cour-
tesy that you give us appropriate credit.)

The $15.00 shareware fee entitles you to use Early Registration and the source code on a 
single computer. Please contact us for information on site licensing. If you use any of 
the source code in your own projects and need to provide source either as part of a soft-
ware contract or to be placed in software escrow, please contact us for source licensing 
information.

User Interface

The user interface to Early Registration is simple and self-explanatory. However, if you 
aren’t comfortable using the program without explicit documentation, the following 
information should be useful.

The File Menu The File Menu contains the usual set of items.

The Open… command displays a standard open file dialog allowing 
you to select a resource file (file type of rsrc or RSRC).

The Close command closes the current window.

The Save command creates a source file from the currently open 
resource file.
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The Save As… command allows you to save the source file with a different name or in a 
different location.

The Quit command quits the application.

The Edit Menu The Edit Menu contains the standard editing commands, 
plus a couple of extras.

The standard editing commands should be self-explanatory.

The Edit Standard Database… command displays an editor 
that enables you to modify the contents of Early Registra-
tion’s standard database — that is, the database of standard 
PowerPlant objects. See below.

The Edit Local Database… command displays an editor that enables you to modify the 
contents of Early Registration’s local database — that is, the database of your custom 
objects. See below.

Note: Database editing is disabled in the Early Registration Demo.

The Main Menu Once you open a resource file, Early Registration parses the PPob resources in it and 
displays the main window.

In this case, we have opened a file named “ER.PPob”. Notice that the program has gen-
erated a default name (“RegisterClass_ER_PPob”) for the registration function. You can 
change the name if you wish.

In this example, all of the classes defined in ER.PPob’s PPob resources are known 
except for the one whose class_ID is “Edit”.
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To edit an object (from either list), either click once and choose Modify or double-click.

An editor dialog appears.

Using this dialog, you can edit 

• the class_ID field. (This is primarily useful when you are creating a new definition, 
rather than editing an existing one.)

• the class name. This is the name used in the RegisterClass_ macro.

• the include file name. This is the name using in the #include line for this class in the 
output source file.

• the format used for #including the file. You must specify either angle brackets or 
quotes.

• the save option for this definition. You can instruct Early Registration to save this 
definition in its System Database, in its Local Database, or to bypass saving the defi-
nition.

When everything has been defined, click OK to process the entry. If you were editing an 
unknown entry, the entry is moved from the unknown to the known file list.

Note: In Early Registration Demo, the modifications to the system or local databases 
will not be saved.
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Editing Databases In Early Registration (although not in the Demo), you can edit the contents of the Early 
Registration databases by selecting either “Edit Standard Database…” or “Edit Local 
Database…” from the Edit Menu. In both cases, the same editor window is used.

To add a new entry to the database (for example, to define classes you know you’ll be 
using ahead of time), type information into the editor section of the screen and click 
Add.

To delete an existing entry, select it from the list and click Delete.

To examine an existing entry, select it from the list — its data will appear in the editor 
section of the screen. If you make any changes in the editor section, they will automati-
cally be saved when you either select a different item or click a button.

Shareware Registration

If you wish to receive a full working version of Early Registration and complete source 
code, just send a check or a purchase order in the amount of $15.00 (US currency only) 
to

Early Registration
Aurbach & Associates, Inc.
9378 Olive Street, Suite 102
St. Louis, MO 63132 USA

We are sorry, but we are unable to accept credit cards or payment over the Internet at 
this time. Be sure to include your eMail address and a telephone number where we can 
reach you (in case we have trouble with eMail) with your order.

If you have any questions or need technical assistance, we can be reached by phone at 
1–800–774–7239 (in the US) or 314–432–7577. Our fax number is 314–432–7072. And 
we’re always happy to respond via eMail at mailto:aurbach@aol.com.
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Legalese

Early Registration, the Early Registration Demo, and the Early Registration source code 
is copyright ©1997 by Aurbach & Associates, Inc. Aurbach & Associates retains all 
rights to these products.

Payment of the shareware fee of $15.00 US entitles you to use Early Registration on a 
single computer. In addition, you may use the supplied source code in in-house, share-
ware or commercial applications without royalty or fee, provided that you do not dis-
tribute the source code in human-readable form. Please contact Aurbach & Associates 
for a source code license if you need to provide source code as part of a software con-
tract or to place in escrow.

Early Registration, the Early Registration Demo, and the Early Registration source code 
are provided AS IS, without any statement of merchantizability or fitness for any use. 
Aurbach & Associates will not be responsible for any damages of any kind whatsoever.

While Aurbach & Associates believes Early Registration to be a stable and reliable 
product, Aurbach & Associates makes no guarantees to fix bugs or make enhancements 
to the product. However, Aurbach & Associates will provide best-effort technical sup-
port for the product.


